Sustainment Management System™

U.S. Army Corps of Engineers
Engineer Research and Development Center

Installation Guide
Version 3.5 DoD

Authors:
Matthew E. Richards
Andrew J. Valentine
Mark E. Fisher
Brody H. Finney

Editor:
Audrey J. Fisher

Revised October 2019
## Contents

1 Installation and Configuration ........................................ 5

1 Document History ..................................................... 7

2 Getting Started ....................................................... 9

2.1 About this Guide .................................................. 9

2.2 Using this Guide .................................................. 9

3 System Requirements .................................................. 11

3.1 Enterprise Configuration .......................................... 11

3.1.1 SQL Server .................................................. 11

3.1.2 Application Server .......................................... 11

3.2 Single Server Configuration ...................................... 11

4 Client Requirements ................................................ 13

4.1 Supported Web Browser .......................................... 13

4.2 Microsoft Silverlight ............................................ 13

5 Installation .......................................................... 15

5.1 Summary .......................................................... 15

5.2 Server Requirements ............................................. 15

5.2.1 Windows Server ............................................. 15

5.2.2 SQL Server .................................................. 15

5.2.3 Application Server (Single Server Configuration) ............. 15

5.2.4 Application Server (Enterprise Configuration) ............... 15

5.3 Perform Installation Prerequisites ................................ 16

5.3.1 Check PowerShell Version .................................. 16

5.3.2 Create User Account ........................................ 16

5.3.3 Add Required Features and Roles: Windows 2012 .............. 16

5.3.4 Add Required Features and Roles: Windows Server 2008 R2 .... 18

5.3.5 Install Microsoft Access Database Engine 2010 Redistributable .... 19

5.3.6 Install SQL Server Features .................................. 19

5.4 Install SMS Files .................................................. 19

5.5 Create Database ................................................... 20

5.5.1 Configure Database Name ..................................... 20

5.5.2 Create Database Scripts Using PowerShell ....................... 20

5.5.3 Move Scripts to Database Server ................................ 21

5.5.4 Execute Database Create Schema Script ....................... 21

5.5.5 Grant Database Role .......................................... 21

5.5.6 Execute Database Insert Data Script .......................... 21

5.6 Create Web Application .......................................... 21

5.6.1 Create SMS Application Using PowerShell ..................... 21

5.6.2 Set SMS Administrator Account Password ..................... 21

5.6.3 Open SMS Application Using Internet Explorer ................ 22
### Table of Contents

5.7 Configure the Service ................................................. 22
  5.7.1 Modify Service on IIS Server .................................. 22
  5.7.2 Additional Configuration Options .............................. 22
5.8 Configure Custom Reports (Optional) ............................. 22
  5.8.1 Install SQL Server Reporting Services (SSRS) ............... 22
  5.8.2 Configure the SMS Inventory database ........................ 23

II Appendix ....................................................................... 25

A System Configuration Worksheet ................................. 27
Part I

Installation and Configuration
Chapter 1

Document History

<table>
<thead>
<tr>
<th>Revision Number</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.5</td>
<td>October 2019</td>
<td>Microsoft Silverlight requirement stands.</td>
</tr>
<tr>
<td>3.5</td>
<td>August 2019</td>
<td>Updated screenshots for &quot;Install SMS Files.&quot;</td>
</tr>
<tr>
<td>3.4.1</td>
<td>November 2018</td>
<td>Corrected variable name.</td>
</tr>
<tr>
<td>3.3.12</td>
<td>April 2017</td>
<td>IMPACT database no longer in use.</td>
</tr>
<tr>
<td>3.3.10</td>
<td>December 2016</td>
<td>Installation requirements.</td>
</tr>
<tr>
<td>3.3.7</td>
<td>July 2016</td>
<td>Revised steps and added Windows 2012 installation.</td>
</tr>
<tr>
<td>3.3</td>
<td>October 2015</td>
<td>Added Silverlight requirement.</td>
</tr>
<tr>
<td>3.2</td>
<td>March 2015</td>
<td>Created Document</td>
</tr>
<tr>
<td>0.2</td>
<td>January 2015</td>
<td>Created Document</td>
</tr>
<tr>
<td>0.1</td>
<td>October 2014</td>
<td>Created Document</td>
</tr>
</tbody>
</table>

Table 1.1: Document History
Chapter 2

Getting Started

2.1 About this Guide

This guide is written to provide an example procedure for installing and configuring the Sustainment Management System™ (SMS). The procedure described here is for a full installation.

See the corresponding Sustainment Management System™ System Administration Guide for information about

- The procedure to install updates;
- Customizing your installation; or
- Managing this product.

2.2 Using this Guide

A System Configuration Worksheet listing variables used in the guide may be found in Appendix A.

IMPORTANT: The System Configuration Worksheet should be completed prior to or during installation of this product.

Variable names are presented in angle brackets (for example, <VAR_APP_POOL>) and are used to record and reference installation parameters. Where these variables appear in the instructions, the corresponding value from the System Configuration Worksheet (Appendix A) should be substituted.
Chapter 3

System Requirements

3.1 Enterprise Configuration

3.1.1 SQL Server

- Windows Server 2012R2 Standard
- SQL Server 2014 Service Pack 2 (12.0.5000.0)
- 400 MB free storage per million square feet of managed inventory
- 2.0 GHz or faster processor, 64-bit, 4+ cores
- 8 GB RAM

*Note: Support for SQL Server 2008 R2 and SQL Server 2008 Express ended December 2016.*

3.1.2 Application Server

- Windows Server 2012R2 Standard
- Internet Information Services 8 (8.5.9600.16384)
- 4 GB of free storage plus desired image storage
- 2.0 GHz or faster processor, 64-bit, 4+ cores
- 8 GB RAM with an additional 100 MB per concurrent user

*Note: Support for Windows Server 2008 R2 ended December 2016.*

3.2 Single Server Configuration

- Windows Server 2012R2 Standard
- SQL Server 2014 Service Pack 2 (12.0.5000.0)
- Internet Information Services 8 (8.5.9600.16384)
• 4 GB of free storage plus desired image storage and 400 MB free storage per million square feet of managed inventory
• 2.0 GHz or faster processor, 64-bit, 4+ cores
• 8 GB RAM with an additional 100 MB per concurrent user

Chapter 4

Client Requirements

4.1 Supported Web Browser

Internet Explorer versions 10 and above are supported. It is recommended to add the URL of the SMS application to your list of trusted sites.

4.2 Microsoft Silverlight

Microsoft Silverlight 5 is a client-side system requirement for running BUILDER’s Functionality and Scenario Visualization features.
Chapter 5

Installation

5.1 Summary

The instructions in this chapter are tailored to installation in the enterprise configuration. Differences for a single-server configuration will be noted.

The enterprise configuration assumes that the application server and the SQL Server are on separate machines. This supports a greater number of users by distributing the load across multiple servers.

5.2 Server Requirements

5.2.1 Windows Server

If not already created, build a Windows Server 2012R2 Standard machine.

5.2.2 SQL Server

Install SQL Server 2014 Service Pack 2 (12.0.5000.0). Install SQL Server Reporting Services on the same server, the application server, or a different server as needed for load distribution.

In SQL Server 2014, select the following as shown in Figure 5.1:

- Database Engine Services
- Management Tools.

5.2.3 Application Server (Single Server Configuration)

Configure the server with (1) the Application Server role and (2) the Web Server (IIS) role.

*Note for Windows 2008:* Configure the Windows Server with an IIS application server role.

A recommended step at this point is to install the .NET Framework prior to installing the SMS. Although recommended, this step is optional because the SMS installer includes the .NET Framework.

5.2.4 Application Server (Enterprise Configuration)

Build another Windows Server 2012R2 Standard machine and configure it with the Web Server (IIS) role.

*Note for Windows 2008:* Configure it with an IIS application server role.

A recommended step at this point is to install the .NET Framework prior to installing the SMS. Although recommended, this step is optional because the SMS installer includes the .NET Framework.
5.3 Perform Installation Prerequisites

5.3.1 Check PowerShell Version

1. Open the SMS PowerShell.
2. Type `$PSVersionTable.PSVersion` at the prompt.
3. If the version is less than 4, download and install Windows Management Framework 4.0

Note: Choose Windows6.1-KB2819745-x64-MultiPkg.msu

5.3.2 Create User Account

Depending on the type of SQL Server authentication, create either a domain account or a local account for the application pool <POOL_IDENTITY>:

1. For Trusted Authentication, a domain account is recommended.
2. When using SQL Server Authentication, a local account may be used. This ensures least privilege.

5.3.3 Add Required Features and Roles: Windows 2012

1. Open the Server Manager Snap-in.
2. Select Dashboard in the left pane.
3. Click on Manage in the top right corner.
4. From the dropdown list, select **Add roles and features**.

5. Click **Next**.

6. Make sure that the radio button "Role-based or feature-based installation" is selected.

7. Click **Next**.

8. Select a server or virtual hard disk.

9. Click **Next**. The left column should show "Select Server Roles" as the active location. *(See Figure 5.2)*.

10. Optional: Select **.NET Extensibility 4.5**.

11. Click **Next** to accept the defaults. The left column should now be at "Select Features".

12. Select **.NET Framework 4.5 Features\ASP.NET 4.5 or higher**.

13. If using SQL 2014, select **.NET Framework 3.5 also if this was specified during SQL installation**.

14. Select **WCF Services\HTTP Activation**.

15. Confirm in the dialog box.

16. Click **Next**.

17. Click **Next**.

18. Click **Next**.

19. Click **Install**.

20. After the installation has completed, click the **Close** button.
5.3.4 Add Required Features and Roles: Windows Server 2008 R2

1. Open the Server Manager Snap-in.

2. Select Features in the left pane.

3. Click the Add Features link in the right pane.

4. Select .NET Framework 3.5.1 Features.

5. A dialog box may open; if so, click the Add Required Role Services checkbox.

6. Click Next.

7. Click Next.

8. Select Application Development\ASP.NET (See Figure 5.3).

9. A dialog box may open; if so, click the Add Required Role Services checkbox.

10. Select Common HTTP Features\Static Content.

11. Select Management Tools\IIS Management Console.

12. Click Next.

13. Click Install.

14. After the installation has completed, click the Close button.
5.3.5 Install Microsoft Access Database Engine 2010 Redistributable


5.3.6 Install SQL Server Features

SQL Server 2014 SP2 features needed for updating the database through PowerShell are the following:

1. Msodbcsql.msi (id=36434)
2. msSqlCmdLnUtils.msi (id=36433)

If you are using SQL Server 2014 SP2, also download and install the following:

1. sql.cli.msi

5.4 Install SMS Files

1. Open sustainment-management-system-<VERSION_NUMBER>-x86-(<LICENSEEE>).exe
2. If prompted by Windows Security, click Run.
3. Click Next (See Figure 5.4).

![Figure 5.4: SMS Installer Welcome](image)

4. Select I accept the terms in the License Agreement.
5. Click Next.
6. Verify that all features are selected (See Figure 5.5).
7. Select the Installation Folder tab.
8. Verify the installation path.
9. Click Next.
10. Click Install.
11. After the installation is complete, click Finish.

5.5 Create Database

5.5.1 Configure Database Name

Refer to the System Configuration Worksheet for the values of variables in angle brackets.

1. Open SMS PowerShell from the Start Menu.
2. Type `Set-SMSDatabaseNames -DatabasePrefix "<WEB_APP_NAME>".`

*Note:* This configures the database name for this session. If you want to specify an existing database name instead of applying a database prefix, use the `InventoryDatabaseName` parameter instead of `DatabasePrefix`.

5.5.2 Create Database Scripts Using PowerShell

1. Use the same SMS PowerShell session. Refer to the System Configuration Worksheet for the values of variables in angle brackets.
2. Type `Export-SMSDatabaseScripts -DatabaseServer "<SQL_SERVER_NAME>" -winAuthentication.`
**Note:** This configures the database for Trusted Authentication. If you want to specify SQL Server Authentication, use the `-sqlAuthentication` switch with the `-DatabaseUser` parameter. After typing `-DatabaseUser "<SQL_AUTH_USERNAME>"`, you will be prompted for the associated password.

3. Do not close the PowerShell session, because it will be needed to complete the installation.

### 5.5.3 Move Scripts to Database Server

Copy the folder specified by the Export-SMSDatabaseScripts command to the database server.

### 5.5.4 Execute Database Create Schema Script

1. Open SQL Server Management Studio with a user that has permissions to create a database.
2. Open `SMS_create_script.sql` from the folder you just copied in **5.5.3**.
3. Execute the script to create the database schema.

### 5.5.5 Grant Database Role

Grant `<POOL_IDENTITY>` the db_owner role to the database and close SQL Server Management Studio.

### 5.5.6 Execute Database Insert Data Script

1. Open a command prompt on the database server.
2. Change the directory to the folder with the database scripts copied in **5.5.3**.
3. To load required data for a new SMS database, either double-click on `.\SMS_bcp_data.bat` OR type `.\SMS_bcp_data.bat` and press Enter. The loading process may take a few minutes.
4. Close the command prompt and return to the IIS server.

### 5.6 Create Web Application

#### 5.6.1 Create SMS Application Using PowerShell

Refer to the System Configuration Worksheet for the values of variables in angle brackets.

Using the previously opened PowerShell session, type

```
Install-SMSApplication -Site "<DEFAULT_WEBSITE>" -Name "<WEB_APP_NAME>" -DatabaseServer "<SQL_SERVER_NAME>" -ApplicationPoolUser "<POOL_IDENTITY>" -winAuthentication -clearLogfile -verbose
```

**Note:** This configures the database for Trusted Authentication. If you want to specify SQL Server Authentication, use the `-sqlAuthentication` switch with the `-DatabaseUser` parameter. After typing `-DatabaseUser`, enter the value for `<SQL_AUTH_USERNAME>`. You will be prompted for the associated password.

#### 5.6.2 Set SMS Administrator Account Password

1. Type `Set-SMSAdministratorPassword -Name "<SQL_AUTH_USERNAME>"`
2. As prompted, enter a password for the SMS Administrator account. If you keep the System Configuration Worksheet (Appendix A) in a secure place, this password may be entered in the Worksheet as `<ADMIN_PASSWD>`.
5.6.3 Open SMS Application Using Internet Explorer

1. Open Internet Explorer.

2. Open http://localhost/<WEB_APP_NAME>

5.7 Configure the Service

5.7.1 Modify Service on IIS Server

Configuring the SMS Service as described below will enable Rollup and Scenarios.

1. At the upper right, select Tools, (Alternatively, for Windows Server 2008, open the Administrative Tools -> Services snap-in, and skip the next step.)

2. From the dropdown, select Services.


4. Change Startup Type to Automatic.

5. Select the Log On tab.

6. Change the Log on as to “This account” and fill in the <POOL_IDENTIY> configuration settings.

7. Click OK but do not close Services.

8. Open SMS Service Configuration from the Start menu.

9. Click File -> Open and search for the ImpactConfiguration.xml file located in “%ProgramFiles%\ERDC-CERL\SMS\SMS Service”.

10. Click Settings -> New and fill out the form.

11. After filling out the form, click File -> Save.


5.7.2 Additional Configuration Options

For further configuration options to customize your installation, and for information about managing this product, see the corresponding Sustainment Management System™ System Administration Guide.

5.8 Configure Custom Reports (Optional)

Below are instructions for installing and configuring the software necessary for publishing custom reports. For how to publish custom reports, see the Sustainment Management System™ System Administration Guide.

5.8.1 Install SQL Server Reporting Services (SSRS)

1. Install SSRS on the SQL Server or on a different server, to offload report generation.

2. On the System Configuration Worksheet, enter that server’s machine name as the value for <SSRS_NAME>. Alternatively, if the machine has a URI, that could also be used as the value for <SSRS_NAME>.
5.8.2 Configure the SMS Inventory database

To configure the SMS inventory database to use SSRS custom reports,

1. Open SQL Server Management Studio.

2. On the inventory database, run the three-command update script below to enable remote processing.
   The first command tells the server that you want to use custom reports. The second command specifies the report server location. The third command gives the location where the reports will be published to.

```
update [dbo].[Configuration]
    set [ConfigValue] = 'True'
where Configuration.ConfigName = 'UseRemoteCstmRpts'
go

update [dbo].[Configuration]
    set [ConfigValue] = '<SSRS_NAME>/ReportServer'
where Configuration.ConfigName = 'CstmRptSvrURI'
go

update [dbo].[Configuration]
    set [ConfigValue] = '/Custom Reports/<WEB_APP_NAME>/Reports'
where Configuration.ConfigName = 'CstmRptSvrRoot'
go
```
Part II

Appendix
Appendix A

System Configuration Worksheet

The following table presents installation parameter variables, in alphabetical order. It is recommended to fill in the values for these variables either in advance of or during installation.

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;ADMIN_NAME&gt;</td>
<td>System administrator user name</td>
<td>For basic installation this will always be &quot;Administrator&quot;</td>
</tr>
<tr>
<td>&lt;ADMIN_PASSWORD&gt;</td>
<td>System administrator password</td>
<td></td>
</tr>
<tr>
<td>&lt;DEFAULT_WEBSITE&gt;</td>
<td>Default web domain for the SMS application</td>
<td>By default, this is &quot;Default Web Site&quot;</td>
</tr>
<tr>
<td>&lt;LICENSEE&gt;</td>
<td>Licensee alias as issued by the SMS vendor</td>
<td></td>
</tr>
<tr>
<td>&lt;POOL_IDENTITY&gt;</td>
<td>Domain or Local user that the application will run-as</td>
<td></td>
</tr>
<tr>
<td>&lt;SQL_AUTH_USERNAME&gt;</td>
<td>SQL Authentication user name</td>
<td></td>
</tr>
<tr>
<td>&lt;SQL_SERVER_NAME&gt;</td>
<td>Name of the SQL server</td>
<td></td>
</tr>
<tr>
<td>&lt;SSRS_NAME&gt;</td>
<td>Name of the server where SSRS is installed</td>
<td></td>
</tr>
<tr>
<td>&lt;VERSION_NUMBER&gt;</td>
<td>SMS version number being installed</td>
<td></td>
</tr>
<tr>
<td>&lt;WEB_APP_NAME&gt;</td>
<td>Name of the web application that the SMS is installed into</td>
<td></td>
</tr>
<tr>
<td>&lt;WEB_APP_ROOT&gt;</td>
<td>The path to the web application root directory*</td>
<td></td>
</tr>
</tbody>
</table>

*The path to the web application root directory will be the concatenation of three items, connected by two single backslashes:

1. Where the inetpub directory is (followed by a backslash)
2. The value of <DEFAULT_WEBSITE> (followed by a backslash)
3. The value of <WEB_APP_NAME>